lstd.net
当前位置:首页 >> 为什么在我的MyEClipsE里不能用jDk8里新增的类。为... >>

为什么在我的MyEClipsE里不能用jDk8里新增的类。为...

因为到目前为止,Myeclipse最高支持到1.7,1.8还不支持,相信不久后的新版本应该会支持的!!!

myeclipse自带编译器,不是用jdk自带的编译器,所以你选择的只是jre也就是所谓的java基础的jar包,你新建工程的时候他会要求你选择相应版本的jre,建议myeclipse的编译器版本与jar包的版本一致.选择编译器版本的方法如下图所示:

使用jdk的版本和编译的目标版本不是一回事.使用JDK8 可以编译1.5, 1.6 等等.但是从图中看 你的eclipse貌似不支持编译成1.8的

支持的,不过版本有点高.建议用1.7或者1.6版本在window -preference --myeclipse----server ---tomcat下配置tomcat;在window -preference --java---jre下配置jdk即可.

哎,让上面的回答给愁死了~~ 按照我的方法做~ 首先:你必须先确定你的jdk1.42安装好了!1.4好像要手工配置环境吧~这个jdk的配置你应该会吧~就是高级环境那~~ 进入正题 在myeclipse里面进入window--->选择最后一个preferences会出现一个配置界面,--->然后找到java选项里面有一个installed jres的选项,点击右边会出现一个列表!里面有你现在用到的jdk版本,如果只有1.5那就点add 加入你的1.4路径就可以了~弄好以后ok出来把1.4打钩就可以了~以后想换回来的话再进来选择你需要的版本就可以了~~ 先试试看!!

下载一个jar包,然后运行就可以了,我给你

因为你的myeclipse版本还不支持这些特性,可以看看myeclipse有没有最新版本.据我所知eclipse已经有新版本对java8进行支持.可以去官网下载看看

桌面--我的电脑--右键--属性--高级--环境变量在变量Path中增加C:\Program Files\Java\jdk1.6.0_04\bin;增加变量JAVA_HOME,值为C:\Program Files\Java\jdk1.6.0_04试一下,配置好java的类库路径,应该就没问题了.

因为我不知道你的是英文版的还是中文版的,所以下面 英文中文我都说一遍=====================1、打开myeclipse 2、点击左上角的 “file(文件)” ---> new(新建)--->Java Project(Java工程)3、这时候会弹出一个窗口,叫你填写

不影响的.default的意思是以后你新建的java类项目将使用这个jdk进行编译和运行.

网站首页 | 网站地图
All rights reserved Powered by www.lstd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com